Etikettarkiv: bash

Shellshock

Verifiera om en Linux-dator är öppen för Shellshock med:

env 'VAR=() { :;}; echo Bash is vulnerable!' bash -c "echo Bash Test"

Om texten

Bash is vulnerable!

skrivs ut behöver datorn uppgraderas.

För att endast uppgradera bash kan du köra kommandot:

sudo apt-get update && sudo apt-get install --only-upgrade bash

Avsluta med att kontrollera igen om datorn är utsatt. Nu ska ENDAST texten

Bash Test

skrivas ut.